When I try to upgrade wordpress automatically to 3.5.1 from 3.4.1, getting following error.

When I try to upgrade wordpress automatically to 3.5.1 from 3.4.1, getting following error.

FastCGI Error
The FastCGI Handler was unable to process the request.

Error Details:

* The FastCGI process exceeded configured activity timeout
* Error Number: 258 (0x80070102).
* Error Description: The wait operation timed out.

HTTP Error 500 – Server Error.
Internet Information Services (IIS)

Solution:

Mostly it’s a memory issue. Your server configuration doesn’t allow to run the script long enough to finish. I would try to increase memory_limit and max_execution_time settings in php configuration at your host (php.ini file) or Use .htaccess file or contact your hosting to increase the memory.

php.ini file

ini_set('max_execution_time', 300); //300 seconds = 5 minutes
ini_set('memory_limit', '128M'); Change the 128M to your needs

.htaccess file

<IfModule mod_php5.c>
php_value memory_limit 300M
php_value max_execution_time 259200
</IfModule>

Leave a Reply

Your email address will not be published. Required fields are marked *


*